The iPhone 6S, 7, and first-gen SE won’t get iOS 16

No lock screen widgets for you. | Image: Apple

Apple released details about iOS 16 today at its Worldwide Developers Conference, including which phones will be eligible for the update — and which didn’t make the cut. To download iOS 16, you’ll need an iPhone 8 or later, meaning Apple is more or less ending support for the iPhone 6S, iPhone 7, and original iPhone SE.

The iPhone 7 and SE were released in 2016, while the 6S was released in 2015, meaning they received nearly six and seven years of software support, respectively. That is, frankly, a very impressive run. It’s also much longer than Android devices have historically had access to software updates, though Samsung and Google have recently made significant strides in that department. Their midrange and flagship devices now get…

Continue reading…

Go to Source
Author: Allison Johnson